EMAIL MIGRATION APPROACH

Best Practices
Single or Multi-Pass Migration

Copyright by Transend Corporation
# Table of Contents

Section 1:  Overview .......................................................................................................................... 1  
  Single Pass Migration .................................................................................................................... 1  
  Multiple Pass Migration .................................................................................................................. 1  
  Deduping (method 1) ...................................................................................................................... 2  
    Deduping Criteria ....................................................................................................................... 2  
    Migrate Unique Items .................................................................................................................. 3  
    Deduping File Writes .................................................................................................................. 4  
  Incremental Migration (method 2) .................................................................................................. 4  
  Date Range filters .......................................................................................................................... 6  
    Selection Criteria (IMAP) ......................................................................................................... 6  
    Date Range ............................................................................................................................... 7  
    Message Date Range .................................................................................................................. 8  
    Calendar Date Range ................................................................................................................ 8  
    Task Date Range ........................................................................................................................ 9  
  Testing Recommendations ............................................................................................................. 9  

Section 2:  Single Pass Migration .................................................................................................... 11  
  SINGLE PASS MIGRATION PLAN CHECKLIST ........................................................................ 11  

Section 3:  Multiple Pass Migration ................................................................................................ 13  
  Pass 1 - Email ONLY .................................................................................................................... 13  
  GO LIVE ....................................................................................................................................... 14  
  Pass 2 – Migrate All Calendar, all Contacts and all Tasks ............................................................ 14  
  MULTIPLE PASS MIGRATION PLAN CHECKLIST ..................................................................... 15  

Section 4: Calculating Migration Time .............................................................................................. 17
Section 1: Overview

There are multiple migration approaches that are appropriate for different migration scenarios. Transend Migrator migrates the user Email, Calendar, Address Book and Tasks in a single configuration file or in separate configuration files.

Single Pass Migration

Transend Migrator can migrate Email, Calendar, Address Book and Tasks in a one-pass migration.

1. Go Live – MX record cutover or email forwarding planned for a specific date (usually a Friday night) to allow changes to propagate the internet.

2. Migrate Email, Calendar, Address Book and Tasks. If there are large mailboxes, you should migrate Calendar, Address Book and Tasks first since these will complete quickly. Once they are finished migrating, then proceed to migrate Email.

3. If necessary, remediate any failed or incomplete migrations and re-run the migrations using a deduping option to apply to all Email, Calendar, Address Book and Tasks.

Transend Migrator provides two different methods to migrate data without duplicating data. One method should be enabled and used from the start to the end of the migrations. Transend Migrator is a read/write process each time the migration is run. The two methods that will not duplicate data are Deduping (applies to Email, Calendar, Address Book and Tasks) and Incremental Migration (applies to Email only for selected email systems).

Note: Date Range filtering options such as IMAP Selection Criteria (applies to IMAP Email only) or Date Range (applies to Email, Calendar and Tasks), Message Date Range (applies to Email only), Calendar Date Range (applies to Calendar only) and Task Date Range (applies to Tasks only) will migrate in the specified Date Ranges but if a migration is re-run with the same Date Range or Selection Criteria without Deduping or Incremental Migration enabled then data will be duplicated from the specified date range.

Multiple Pass Migration

A multiple-pass migration is when you migrate older email data before the “Go Live” (MX record switchover date), and then run a second pass migration to migrate All Calendar, All Address Book and All Tasks. This approach generally helps maintain the best calendar fidelity. Data can also be post migrated after the user is live in the new system. It is important to consider that any Date Range, Calendar Date or Task Date Range needs to include the start/end date of a recurring/repeat calendar or task otherwise it will be skipped in the migration.
1. Pass 1 – Pre-migrate Email (with Deduping or Incremental Migration enabled) 1-2 weeks prior to migration, remediate and re-run any migrations that fail or do not complete. The start of the email pre-migration should be based on the total amount of data and the data size to be migrated. Multiple migration workstations can be enabled to run in parallel, but each user should be run only on the same workstation when using Deduping or Incremental features so Transend Migrator can access the user dedup or incremental log to skip or migrate the items.

NOTE: Office 365 has throttling that causes the migrating data to be rejected by the Office 365 Servers, **ERROR 500 Server Not Responding, try again later.** Re-running the migrations will migrate the data that was throttled. You can make a Microsoft Support Request to reduce or remove throttling during your migration timeline.

NOTE: GSuite/Google has daily limits when migrating with the Google API and Google IMAP, which needs to be considered. Migrations to or from GSuite run daily until the throttling occurs for 1-2 weeks in advance based on the mailbox size in GSuite. Data can also be migrated after the user is moved to the new system.

2. Go Live – MX record cutover or email forwarding planned for a specific date (usually a Friday night) to allow changes to propagate the internet.
3. Pass 2 – Migrate All Calendar, Address Book and Tasks – these migrations run quickly, remediate and re-run any migrations that do not complete.
4. Pass 3 – Migrate Email again to convert any new email that was delivered during the Go Live/MX Record cutover.

NOTE: Data can also be migrated after the user is in the new email system.

When the amount of data is very large, a multiple-pass migration is recommended as it allows the migration team to pre-migrate and/or post migrate older data that does not change (such as email). Testing is very important to determine what configuration settings are necessary and what the rate of migration is in your environment. RAM, CPU, Network and Server Availability all impact the migration rate.

NOTE: Anti-virus and email scanning programs can slow or even quarantine attachments and should be disabled during migrations.


**Deduping (method 1)**

**Deduping Criteria**

This feature allows you to re-run migrations that do not complete, require remediation or pre-migration of email. Deduping will dedup email, calendar, address book and tasks but if a value changes (i.e. time/date changes) then the calendar entry could appear to be migrated again so calendar, address
book and tasks should be migrated when the user is live in the new system. This cutover is best performed over a weekend with the most up to date items in calendar, address book and tasks. Specify a Deduping Criteria, BSDNRFHUA, this criteria will track by Body, Sender, Date, Subject, Folder, Header, Unique Id, Attachments (enabling A will slow the migration performance).

Click Migration Options > Custom Options > General

Migrate Unique Items

Transend Migrator will create the c:\ProgramData\Transend (this is a hidden folder in Windows, you can unhide hidden folders or type in the full path in Windows to another local c:\drive folder. For example c:\dedup\$Var1.dat
Deduping File Writes

Write to the user.dat file as the data is migrated, otherwise Transend Migrator will write the user.dat after the migration completes.

OR

Incremental Migration (method 2)

This feature tracks the Email ONLY via the Incremental Migration option.

Transend Migrator tracks the items migrated by folder and by last unique id migrated. Then when an email migration is re-run Transend will check the incremental file user.dat file and migrate the next highest unique id in that folder. When using Incremental Migration for email, you need to ensure the other deduping options are disabled.

Deduping can still be used to track what is being migrated for Calendar, Address Book and Tasks in a second configuration file. Do NOT use deduping with Incremental Migration in the same Transend Migrator config.tmd file.

The Incremental Migration feature is available for Exchange Web Services (EWS) for migrations to Exchange 2010, Exchange 2013/2016 and Office 365 EMAIL. Use deduping if migrating Calendar, Address Book and Tasks in a second configuration. Do not run incremental and deduping features in the same configuration.tmd file.
The Incremental Migration feature is available for GSuite/Google/Gmail Email. Use deduping if migrating Calendar, Address Book and Tasks in a second configuration. Do not run incremental and deduping features in the same configuration .tmd file.
The *Incremental Migration* feature is available for IMAP Email. Use deduping if migrating Calendar, Address Book and Tasks in a second configuration. Do not run incremental and deduping features in the same configuration .tdm file.

Date Range filters

Date Ranges are another way to filter migrated data, but if the same migration is run in the same Date Range or Selection Criteria then this will duplicate the data in the specified Date Range.

**Selection Criteria (IMAP)**

This feature is available for IMAP Email ONLY.

This option allows for server based selection criteria. Use this option to migrate between date ranges on most IMAP Servers. This method is faster because the date range search will happen on the IMAP server rather than on the local migration workstation. If a migration is re-run with the same Selection Criteria and No Deduping or Incremental Migration options enabled then the migration run will duplicate already migrated data within the specified date range.

**SINCE 14-Jun-2010 BEFORE 01-Jan-2020**
**Date Range** (applies to Email, Calendar, and Tasks).

If a migration is re-run with the same Date Range and No Deduping or Incremental Migration options enabled then the migration run will duplicate already migrated data within the specified date range. If a future or repeating calendar/task does not have a start/end date within the repeat or future item it will not be migrated.

01/01/2010-12/31/2028
**Message Date Range** (applies to Email Only)

![Custom Options](image)

**Calendar Date Range**

This feature applies to Calendar Only. If a migration is re-run with the same Calendar Date Range and No Deduping or Incremental Migration options enabled then the migration run will duplicate already migrated data within the specified date range. If a future or repeating calendar/task does not have a start/end date within the repeat or future item it will not be migrated.

01/01/2010-12/31/2028
Task Date Range

This feature applies to Tasks Only. If a migration is re-run with the same Task Date Range and No Deduping or Incremental Migration options enabled then the migration run will duplicate already migrated data within the specified date range. If a future or repeating calendar/task does not have a start/end date within the repeat or future item it will not be migrated.

01/01/2010-12/31/2028

Testing Recommendations

1. Test migration configuration and check the tmlog-x. Click View > Log Files for errors occurring in the user migration. Search on keywords TM ERROR and TM WARNING.

2. Check the Migration Report which is an Excel spreadsheet that provides details on the batch migration. Click View > Migration Reports.

3. Notepad++ can also be used for large migration tmlog-x and you can also search across the entire batch using this utility. Click Find in Files and point to the batch migration logs located in c:\ProgramData\Transend\NameofConfig folder. Search on keywords TM ERROR and TM WARNING.
4. Migration Throughput – can be determined after test migrations of several user accounts are completed and viewed in the View > Migration Reports. Column O shows the Data Amt (kb) this is your Migration Rate.

5. Determine how many migration workstations will be needed to migrate the amount of data within your timeframe. See Calculating Migration Time at the end of this document.

6. Pilot Migration - Test end-to-end process by conducting a production pilot with select user accounts to generate a feel for the process and understand migration results. You will need to use a mail forward or dual delivery method for email routing prior to changing the MX records.
Section 2: Single Pass Migration

Migrate all Email, Calendar, Address Book and Tasks in one migration run, remediate and re-run the migrations that fail or do not complete successfully. Transend Migrator has two methods to migrate data without duplicating already migrated data or re-running a failed or incomplete migration, these methods are Deduping (applies to Email, Calendar, Address Book and Tasks or Incremental migration (applies to Email ONLY for selected IMAP, EWs and GSuite).

Configure Transend Migrator appropriately, according to the requirements of your source and target message systems. Ensure that the checkbox of all types (Email, Calendar, Address Book and Tasks) are enabled and confirm by viewing the green checkmark within each data type.

NOTE: Transend Migrator does not support the removal of migrated data from the target account after it has been migrated.

SINGLE PASS MIGRATION PLAN CHECKLIST

| PRE-Migration Prep | ✓ Coordinate Training and Training Materials for End Users and Administrators  
|✓ Send communications to Business Units / End Users regarding migration |

| Assess/Plan | ✓ Perform Mail Server Assessment – determine mail data size  
|✓ Perform User PC Assessment to determine that PCs meets requirements for email or webmail client  
|✓ Build and deploy migration workstation or virtual machines  
|✓ Configure and test Transend Migrator  
|✓ Determine what data types will be migrated: Email, Calendar, Address Book, Tasks  
|✓ Run Batch Migration to TARGET – Migration Report Only  
|✓ Check Transend Performance Guidelines for build of VMWare or Physical PC Migration  


✓ Understand throughput rate and plan for X number of migration workstations to process migrations  

✓ Note: Migration Workstation MUST have same time zone as mail server – DO NOT set to UTC Coordinated time, SET to TRUE TIMEZONE same as on-premise servers.

| Target Email System | ✓ Use Guidelines from mail system vendor for target email system deployment  
|✓ Active Directory Prep  
|✓ Digital Certificates Configuration  
|✓ Provision User Accounts and Mailboxes  
|✓ Configure MailFlow and Test  
<p>|✓ Analyze System and Remediate |</p>
<table>
<thead>
<tr>
<th>Pilot</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓ Perform pilot migration with selected production users and remediate if necessary for usability or issues</td>
</tr>
<tr>
<td>✓ Check Dates/Times, Email Repliability, Folders, Email, Calendar, Repeat Calendar, Contacts and Tasks</td>
</tr>
<tr>
<td>✓ Create an Address Translation Table if the user email addresses or display names after migration are not repliable and import via CSV from Migration Options&gt;Address Translation Table&gt;Load from File.</td>
</tr>
<tr>
<td>✓ Test end-to-end process to determine throughput - this determines how many workstations (physical or virtual) are needed to migrate data within a defined timeframe</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Migration</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓ Create CSV spreadsheet for accounts to be migrated in batch, click Batch Migration&gt;Batch Migration Setup and Click Load from File to import the batch CSV file. Be sure to run the user only one workstation or the data will be duplicated.</td>
</tr>
<tr>
<td>✓ Check that all accounts were provisioned correctly using the Batch Migration&gt;Validate Batch Setup Test</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Email Client Deployment</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓ Send End-User Instructions prior to migration to all Business Units</td>
</tr>
<tr>
<td>✓ Enable and Configure Email clients or supported Web Browsers</td>
</tr>
<tr>
<td>✓ Analyze workstations for minimum requirements and correct prior to deployment</td>
</tr>
<tr>
<td>✓ Provide configuration document for Desk Side Support</td>
</tr>
<tr>
<td>✓ Deploy and track install package with settings for email client</td>
</tr>
<tr>
<td>✓ Install / Push to end-users prior to migration</td>
</tr>
<tr>
<td>✓ Setup email client on end user workstation</td>
</tr>
<tr>
<td>✓ Leave copy of End User Help - Migration FAQ and Quick Reference Guide at end-user's workstation, or provide online</td>
</tr>
<tr>
<td>✓ Migrated User Checkpoint - Post Migration Next Day to resolve any issues</td>
</tr>
<tr>
<td>✓ Report, Follow-up, Resolve End User Issues</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Pass 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓ Perform Pass 1 Migration of All Email, Address Book, Calendar and Tasks</td>
</tr>
<tr>
<td>✓ Validate and Remediate and Re-run migrations if necessary.</td>
</tr>
<tr>
<td>✓ Go LIVE - MX RECORD UPDATE - Mail delivery routed to Target system</td>
</tr>
<tr>
<td>✓ Email forwarding can also be used to move users to the target mail system</td>
</tr>
<tr>
<td>✓ Test mail forward or MX record cutover is delivering mail to the target system</td>
</tr>
<tr>
<td>✓ Send confirmation email to users for DAY 1 actions to set up preferences, delegation and email signature</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Legacy System Decommission</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓ Server Decommission</td>
</tr>
</tbody>
</table>
Section 3: Multiple Pass Migration

Pre-migration of email data helps to migrate the largest chunk of email data that does not change, so this data can be pre-migrated before the users are using the new email target system. The benefits of this migration approach are to start migrating user data and fix errors prior to moving the users to the new system. If there are issues, mailboxes can be safely deleted and reset since the users are not using the new target system yet.

NOTE
Transend Migrator does not support the removal of migrated data from the target account after it has been migrated.

Pass 1 - Email ONLY

1-2 weeks prior to Go Live in the New Mail System

1. Enable PRE-Migration Pass 1 Migration for EMAIL only and pre-migrate this older email data, remediate any errors and re-run the migrations.

Select from the options to enable to NOT duplicate already migrated when Transend Migrator re-runs the migration.

2. Enable Deduping feature. Be sure to run the user migration on the SAME migration workstation since the deup file is local to that migration workstation. This applies to all Email, Calendar, Address Book or Tasks for all supported Mail Systems.

OR

Enable Selection Criteria or Incremental Migration custom options. Selection Criteria uses the IMAP server to search for these items faster than using the Date Filters in Transend Migrator. This applies only to IMAP Email ONLY. Calendar, Address Book and Tasks are not tracked will be duplicated if they are not setup using Deduping.

OR

Enable Date Range Options but if you re-run a migration in the same Date Range then you will duplicate the data already migrated. NOTE: If a future or repeating calendar/task does not have a start/end date within the repeat or future item it will not be migrated.

3. Click File > Save Configuration As and name the migration configuration by date/batch so all the migration logs are maintained in their own folder in the config named directory c:\ProgramData\Transend\Date_Batch1_Pass1EmailOnly.tmd.

Run batch migration, check logs and remediate any errors or incomplete migration by re-running the batch migrations that did not complete.
GO LIVE

Determine Go Live date and then cutover the MX Records (or enable an email forward process to deliver the new email to the new mail System).

Pass 2 – Migrate All Calendar, all Contacts and all Tasks

Migrate these items on the weekend of the MX Record cut-over to move the rest of users’ email data to new message system. Calendar, Address Book and Tasks information tends to change, this data should be migrated when the user’s are leaving the legacy email system for the best calendar fidelity.

1. Enable Address Book, Calendar and Tasks migration.

2. Enable deduping custom option. Be sure to run the user migration on the SAME migration workstation since the deup file is local to that migration workstation.

3. DISABLE Selection Criteria or Incremental Migration options. These options do not apply to Calendar, Address Book or Tasks.

4. Click File>Save Configuration As and name the migration configuration by date/batch so all the migration logs are maintained in their own folder in the config named directory c:\ProgramData\Transend\Date_Batch1_Pass2.tmd.

5. Run batch migration, check logs and remediate any errors or incomplete migration by re-running the batch migrations that did not complete.
| PRE-Migration Prep                      | ✓ Coordinate Training and Training Materials for End Users and Administrators  
|                                        | ✓ Send communications to Business Units / End Users regarding migration |
| Assess/Plan                           | ✓ Perform Mail Server Assessment – determine mail data size  
|                                        | ✓ Perform User PC Assessment to determine that PCs meets requirements for email or webmail client  
|                                        | ✓ Build and deploy migration workstation or virtual machines  
|                                        | ✓ Configure and test Transend Migrator  
|                                        | ✓ Determine what data types will be migrated  
|                                        | ✓ Run Batch Migration to TARGET – Migration Report Only  
|                                        | ✓ Check Transend Performance Guidelines for build of VMWare or Physical PC Migration  
|                                        | ✓ Note: Migration Workstation MUST have same time zone as mail server – DO NOT set to UTC Coordinated time, SET to TRUE TIMEZONE |
| Target Email System                   | ✓ Use Guidelines from mail system vendor for target email system deployment  
|                                        | ✓ Active Directory Prep  
|                                        | ✓ Digital Certificates Configuration  
|                                        | ✓ Configure MailFlow and Test  
|                                        | ✓ Analyze System and Remediate  
|                                        | ✓ Provision User Accounts and Mailboxes |
| Pilot                                 | ✓ Perform pilot migration with selected production users and remediate if necessary for usability or issues  
|                                        | ✓ Check Dates/Times, Email Repliability, Folders, Email, Calendar, Repeat Calendar, Contacts and Tasks  
|                                        | ✓ Create an Address Translation Table if the user email addresses or display names after migration are not repliable and import via CSV from Migration Options>Address Translation Table>Load from File.  
|                                        | ✓ Test end-to-end process to determine throughput - this determines how many workstations (physical or virtual) are needed to migrate data within a defined timeframe |
| Migration                             | ✓ Create CSV spreadsheet for accounts to be migrated in batch, click Batch Migration>Batch Migration Setup and Click Load from File to import the batch CSV file. Be sure to run the user only one workstation or the data will be duplicated.  
|                                        | ✓ Check that all accounts were provisioned correctly using the Batch Migration>Validate Batch Setup Test |
| Email Client Deployment               | ✓ Send End-User Instructions prior to migration to all Business Units  
|                                        | ✓ Enable and Configure Email clients or supported Web Browsers  
|                                        | ✓ Analyze workstations for minimum requirements and correct prior to deployment  
|                                        | ✓ Provide configuration document for Desk Side Support  
|                                        | ✓ Deploy and track install package with settings for email client  
|                                        | ✓ Install / Push to end-users prior to migration  
|                                        | ✓ Setup email client on end user workstation  
|                                        | ✓ Leave copy of End User Help - Migration FAQ and Quick Reference Guide at end-user's workstation, or provide online  
|                                        | ✓ Migrated User Checkpoint - Post Migration Next Day to resolve any issues  
|                                        | ✓ Report, Follow-up, Resolve End User Issues |
| Pass 1 | ✓ Perform Pass 1 Migration Email only
✓ Validate and Remediate and Re-run migrations if necessary.
✓ Go LIVE - MX RECORD UPDATE - Mail delivery routed to Target system
✓ Email forwarding can also be used to move users to the target mail system
✓ Test mail forward or MX record cutover is delivering mail to the target system |
| Pass 2 | ✓ Migrate Address Book, Calendar and Tasks
✓ Validate accuracy
✓ Migrate Email
✓ Go Live – Day 1
✓ Report, Follow-up, Resolve End User Issues
✓ Send confirmation email to users in target email system for DAY 1 actions to set up preferences, delegation, email signature etc. |
| Migration Support | ✓ Localized Help desk & Onsite Help Desk to provide end user support |
| Legacy System Decommission | ✓ Server Decommission |
Section 4: Calculating Migration Time

Below are examples of an easy way to calculate how long it will take to complete a migration. Create a simple spreadsheet that lists the total number of gigabytes to migrate, the quantity of workstations you will use, and then the rate of speed your system will migrate. Then, enter a simple formula to calculate how long your migration will complete with one workstation. In these screenshot examples, your formula would be: \((\text{Gigabytes}/\text{Rate})/\text{PC's}\).

In Microsoft Excel, your formula would look similar to: \((E14/E16)/E15\)

**Spreadsheet Example 1**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>E14</td>
<td>Total Quantity of Data to Migrate in Gigabytes</td>
<td>350</td>
</tr>
<tr>
<td>E16</td>
<td>Quantity of PCs to Process the data</td>
<td>1</td>
</tr>
<tr>
<td>E15</td>
<td>Gigabytes per Hour</td>
<td>3</td>
</tr>
</tbody>
</table>

Processing Time For Completion In Hours: 116.67
Number of Days: 4.86

In the spreadsheet example above, it will take 4.86 days to migrate 350 gigabytes of data at the rate of 3 gigabytes per hour. Therefore, you may want to add more machines to complete your project in a shorter amount of time.

**Spreadsheet Example 2**

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Total Quantity of Data to Migrate in Gigabytes</td>
<td>350</td>
</tr>
<tr>
<td>4</td>
<td>Quantity of PCs to Process the data</td>
<td>5</td>
</tr>
<tr>
<td>5</td>
<td>Gigabytes per Hour</td>
<td>3</td>
</tr>
</tbody>
</table>

Processing Time For Completion In Hours: 23.33
Number of Days: 0.97

If you are using a simple formula, add more workstations to your spreadsheet to determine how much faster your project will complete. In Spreadsheet Example 2, the same migration will complete in 23 hours if 5 workstations are used at the same time. Be careful when adding computers to your project, and verify your source/target servers and network can handle the workload. If you are migrating into Microsoft Exchange, we recommend you turn off Transaction Logging so that your Exchange Server will not become overloaded and use up too much disk space. Turn Transaction Logging back on when your migration project is complete.